Autor Tema: Error al tratar de compilar arduino mega2560 compatible  (Leído 631 veces)

lucius

  • Nuevo
  • *
  • Mensajes: 4
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: argentina
Error al tratar de compilar arduino mega2560 compatible
« en: Marzo 17, 2016, 02:30:39 am »
Buenas noches a todos, les vengo a plantear el siguiente problema para ver si a alguno de ustedes les paso algo parecido;
compre una placa arduino neutral mega 2560 r3 , ramps 1.4 y drivers pololu a4988 para empezar a jugar un poco y ver si podia armar algun cnc, hasta ahora todo bien, busque mucho en el foro vi varios videos y fui haciendo pruebas para ir tomandole la mano al arduino, compile uno de los ejemplos que vienen con el programita para compilar el famoso blink y funciono perfecto, pero a la hora de profundizar un poco mas, descargue el cnc control para compilarlo al arduino, pero a la hora de compilarlo me tira el siguiente error



Si alguien me podria decir si es un problema de codigo o un problema externo de la plaquita se lo agradeceria mucho
« Última modificación: Marzo 18, 2016, 03:19:40 am por lucius »

Foshland

  • Moderador Global
  • Usuario de CNCs
  • *****
  • Mensajes: 1400
  • Karma: +23/-4
    • Ver Perfil
  • Ubicación: Ceuta
Re:Error al tratar de compilar arduino mega2560 clon
« Respuesta #1 en: Marzo 18, 2016, 01:59:26 am »
Te aconsejo que metas directamente GRBL para MEGA (no es el mismo que para Arduino UNO). El Cnccontrol esta en dique seco, no lo va a seguir mejorando NGC y casi no lo usa nadie del foro, asi que por lo menos yo ni me acuerdo de los detalles.

Sobre el error, has probado de nuevo el blink? Te carga y funciona bien?? que otros programas le metiste antes de este firmware??


Por ahi leo desde un simple problema de windows hasta un bootloader corrupto, pasando por posiciones de memoria del arduino quemadas. A ver si programas "simples" te funcionan bien
Me sigue fascinando el ingenio humano

lucius

  • Nuevo
  • *
  • Mensajes: 4
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: argentina
Re:Error al tratar de compilar arduino mega2560 clon
« Respuesta #2 en: Marzo 18, 2016, 03:02:12 am »
Hola, recien probe denuevo el blink y funciona y compila todo, le puedo cambiar las variables y volver a compilar y no hay problema, antes de el cnc le habia puesto un firmware que no recuerdo para impresora 3d y tambien me lo compilo bien, el arduino es un NEUTRAL mega 2560 r3; como haria para introducir un grbl al arduino?? si me orientas un poco con eso voy probando para ir descartando el hardware