Autor Tema: Problema al habilitar el ventilador  (Leído 354 veces)

cguerrero1205

  • Nuevo
  • *
  • Mensajes: 131
  • Karma: +1/-0
    • Ver Perfil
Problema al habilitar el ventilador
« en: Marzo 20, 2015, 02:15:40 pm »
Hola, les comento que ya estoy armando la electrónica de mi CNC. Bueno, todo va bien, excepto cuando activo la opción del ventilador, como ven da error al compilar, pensé que era porque la librería thermistor.h no la tenia en la carpeta, así que la busqué y la descargue, pero igual sigue con el mismo error...

Que me recomiendan para solucionar ese problema? De ante mano, gracias (Y)
Todo es posible

ngc1300

  • Administrador
  • Usuario de CNCs
  • *****
  • Mensajes: 2898
  • Karma: +46/-2
    • Ver Perfil
    • cncControl
  • Ubicación: Terrassa
Re:Problema al habilitar el ventilador
« Respuesta #1 en: Marzo 20, 2015, 02:31:21 pm »
has probado a instalar la librería en el IDE de arduino?

cguerrero1205

  • Nuevo
  • *
  • Mensajes: 131
  • Karma: +1/-0
    • Ver Perfil
Re:Problema al habilitar el ventilador
« Respuesta #2 en: Marzo 22, 2015, 03:46:56 am »
has probado a instalar la librería en el IDE de arduino?
Descargue la librería de thermistor y la guardé en la carpeta donde tengo el firmware de la CNC, la recoxe xq cuando abro el .ino aparece arriba en las pestallas adicionales... Pero igual sigue con el problema
Todo es posible

ngc1300

  • Administrador
  • Usuario de CNCs
  • *****
  • Mensajes: 2898
  • Karma: +46/-2
    • Ver Perfil
    • cncControl
  • Ubicación: Terrassa
Re:Problema al habilitar el ventilador
« Respuesta #3 en: Marzo 22, 2015, 07:05:09 am »
creo que hay un problema en la definición de la librería al estar definida con <> espera encontrarla en las librerías del IDE si estuviese definida con "" la buscara en la carpeta del firmware.

Puedes probar dos cosas, o añadir la librería al IDE de arduino y compilar. O cambiar el include a comillas #include "thermistor.h" y compilar.

cguerrero1205

  • Nuevo
  • *
  • Mensajes: 131
  • Karma: +1/-0
    • Ver Perfil
Re:Problema al habilitar el ventilador
« Respuesta #4 en: Marzo 22, 2015, 10:17:09 am »
creo que hay un problema en la definición de la librería al estar definida con <> espera encontrarla en las librerías del IDE si estuviese definida con "" la buscara en la carpeta del firmware.

Puedes probar dos cosas, o añadir la librería al IDE de arduino y compilar. O cambiar el include a comillas #include "thermistor.h" y compilar.
Ok, gracias NGC, lo intentaré (Y)
Todo es posible

cguerrero1205

  • Nuevo
  • *
  • Mensajes: 131
  • Karma: +1/-0
    • Ver Perfil
Re:Problema al habilitar el ventilador
« Respuesta #5 en: Marzo 24, 2015, 11:26:31 pm »
creo que hay un problema en la definición de la librería al estar definida con <> espera encontrarla en las librerías del IDE si estuviese definida con "" la buscara en la carpeta del firmware.

Puedes probar dos cosas, o añadir la librería al IDE de arduino y compilar. O cambiar el include a comillas #include "thermistor.h" y compilar.
Ya lo hice, solucionó ese problema, pero después dio el mismo problema con el #include <lm75.h>, así q hice lo mismo, lo puse entre "", pero después al compilar me arrojaba otros errores, al final no pude configurar el control de temperatura...
Todo es posible