Autor Tema: Comportamiento erroneo de motores  (Leído 176 veces)

Felipe001

  • Nuevo
  • *
  • Mensajes: 3
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: madrid
Comportamiento erroneo de motores
« en: Agosto 04, 2017, 08:22:32 pm »
Saludos al foro. Creo que ya me presenté en su dia, pero actualizo. Jubilado, apasionado de la mecanica pero sin conocimientos academicos, solo lo que he aprendido en este fabuloso foro. He terminado mi modesta cnc casera, motores nema 17, 3 drivers JK0220 a 1A, arduino 1, cnccontrol 2.3.3, grbl 0.9, W xp. Despues de muchas pruebas de calibracion para las varillas, voltajes, micropasos, etc, a satisfaccion, en el montaje final de repente los motores han comenzado un comportamiento absolutamente erroneo, girando en un sentido, a continuacion en el otro. Cables revisados, conexiones aseguradas, otro arduino, cargar de nuevo el GRBL, leer todo lo que he podido y no consigo resolverlo. Me da que los drivers han fallado. Agradeceria algun comentario. Gracias y repito mis felicitaciones al trabajo de los compañeros.

ElHormiGa

  • Aprendiz
  • **
  • Mensajes: 574
  • Karma: +14/-1
    • Ver Perfil
Re:Comportamiento erroneo de motores
« Respuesta #1 en: Agosto 04, 2017, 10:54:21 pm »
quizas pueda ser el shield , habria que revisar también los drivers , cambiarlos de posicion  (me refiero a cambiar el del eje x por el y )
pueden ser parasitos por el cable usb , puede ser el conector usb de la placa base.. inclusive un fallo en los balastos de la luminaria. hay que partir de cero e ir eliminando algunos problemas que tienen estas maquinas.

un saludo
Lo mejor de todo en esta vida  es devolver los conocimientos adquiridos. Es una forma de agradecer a quien te ayudó en algún momento
 
Mi maquina (laser M140)  http://www.cnccontrolapp.com/smf/index.php?topic=225.0
Mi otra maquina (Co2)
http://foro.cnccontrolapp.com/index.php?topic=1550.0

Felipe001

  • Nuevo
  • *
  • Mensajes: 3
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: madrid
Re:Comportamiento erroneo de motores
« Respuesta #2 en: Agosto 05, 2017, 07:34:39 pm »
Muchas gracias por tu rapida respuesta. Estoy de nuevo chequeando desde el principio y de momento parece que es un motor el que está despistado. Vete y pregunta porqué. A proposito, que son los balastos de la luminaria? laser? la mia es fresadora. Otra cosa, cual es el enable del arduino y porque se conecta? Gracias de nuevo

ElHormiGa

  • Aprendiz
  • **
  • Mensajes: 574
  • Karma: +14/-1
    • Ver Perfil
Re:Comportamiento erroneo de motores
« Respuesta #3 en: Agosto 05, 2017, 08:46:29 pm »
Reactancias? Jajaja
Los trafos de los tubos y de las lamparas antiguas de focos.
Yo me pase a led por ese motivo.
Parasitos en la corriente. Me di cuenta una vez que wstaba lasereando y encendi la luz.
El enable es un sistema de seguridad ya que agregando el swich correspondiente tienes que pulsar para que la maquina funcione.
En los grbl viene desactivado . Nadie creo que lo use  :D
Saludos
Lo mejor de todo en esta vida  es devolver los conocimientos adquiridos. Es una forma de agradecer a quien te ayudó en algún momento
 
Mi maquina (laser M140)  http://www.cnccontrolapp.com/smf/index.php?topic=225.0
Mi otra maquina (Co2)
http://foro.cnccontrolapp.com/index.php?topic=1550.0

ngc1300

  • Administrador
  • Usuario de CNCs
  • *****
  • Mensajes: 2904
  • Karma: +48/-2
    • Ver Perfil
    • cncControl
  • Ubicación: Terrassa
Re:Comportamiento erroneo de motores
« Respuesta #4 en: Agosto 07, 2017, 04:14:24 pm »
has mirado las curvas de aceleración y velocidades de los motores, si son excesivas pueden provocar lo que dices