Autor Tema: La CNC no fresa el tamaño correcto  (Leído 398 veces)

gismodes37

  • Nuevo
  • *
  • Mensajes: 1
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: Chile
La CNC no fresa el tamaño correcto
« en: Junio 03, 2019, 05:05:46 pm »
Hola a todos, mi nombre es Guillermo soy nuevo en este foro y aprovecho la oportunidad para hacer esta consulta a los más expertos.
Resulta que arme una fresadora CNC, ya esta funcionando todo de forma manual funciona y respeta las medidas de los movimientos que se ejecutan. "Pero" cuando envió un g.code por ejemplo con un cuadrado de 40mm, este dibuja uno de 4mm, sucede lo mismo con cualquier figura que envíe, para generar el vector e utilizado Corell Draw, Vectric Aspire, Inkscape y en todas las formas sucede lo mismo, un amigo me envió un archivo generado en autocad y lo mismo, ahora paso a detallar las caracteristicas de mi equipo:
* Arduino uno original,
*CNC Shield,
*Drivers A4988 de pololu, la configuración es a Full Step, las transmisiones es en husillos T8 que avanzan 2mm por vuelta, por lo tanto configure grbl en 100 para los 3 ejes, el eje Y lo tengo clonado, los motores son Nema 17 los 4 son iguales, estoy utilizando grvl 0.9, antes utilizaba el 0.8 pero al aparecer ese problema, cambie la placa de arduino y el grbl por el 0.9, pero el problema sigue igual, espero alguien tenga alguna idea o sugerencia, agradezco todas las respuestas.
Les dejo un link a un vídeo de la maquina:  https://www.facebook.com/solucioneselectronicasch/videos/2319579464983253/

pancholaje

  • Nuevo
  • *
  • Mensajes: 7
  • Karma: +0/-0
    • Ver Perfil
  • Ubicación: Argrntina
Re:La CNC no fresa el tamaño correcto
« Respuesta #1 en: Junio 25, 2019, 03:13:36 pm »
Hola estimado buen dia, recien leo el mensaje.
Antes de decir lo que tengo en mente te pregunto, siempre la diferencia es de 10 a 1, es decir si dibujas un cuadrado de 40x40 te lo dibuja de 4x4 y asi con todos los codigos?
Si es asi, tenes mal configurado los parametros del grbl, los steps/mm en cada eje, proba aumentar 10 veces esos parametros y asi no deberias tener mas ese problema.
Espero se solucione, esperamos tus novedades.
Saludos